Stormer FB 370 - Reinstating Points Ignition

Information on the Stormer 2-stroke machines
Posts: 4
Joined: Mon Apr 09, 2018 10:15 pm
Location: Worcs UK

Stormer FB 370 - Reinstating Points Ignition

Postby burga007 » Fri Jan 18, 2019 10:06 am

I wondered if anyone can give me the benefit on their wisdom?

I’m restoring a 1978 Stormer FB 370. I bought the bike as a project. The previous owner had installed an Electrex World electronic ignition. The bike started when I bought it but after 5 or 6 test starts (of no more than 3 or 4 minutes each in duration) I could not get a spark. The problem was identified to be the CDI Unit itself.
I purchased a new CDI box from Electrex World, fitted it and the bike started. Again, after a few test starts, I can’t get a spark.

The CDI unit is fitted to the frame under the tank and is quite close to the exhaust. I’m wondering if the location might be the issue? – heat from exhaust. Although, given the short time the bike has been run, it can’t have got very warm. Also, I wonder if the vibration might be a cause of the problems?
Does anyone have any views on this?

I’m considering converting the bike back to points ignition (as it was designed to be this way out of the factory). I have the hardware as it came with the bike. I also have the AJS Workshop Manual, but the diagrams aren’t very clear. Does anyone have photo’s of the internal parts of the magneto housing showing the stator etc so I can see how the thing should be installed? I’m a bit of a novice so any help/advice will be greatly appreciated. If anyone has any views on the logic of going back to points ignition I’d welcome the feedback.

Member
Posts: 6188
Joined: Wed Sep 01, 2004 12:00 am
Location: WEST SUSSEX UK

Re: Stormer FB 370 - Reinstating Points Ignition

Postby SPRIDDLER » Fri Jan 18, 2019 2:05 pm

AJS still offer parts plus providing spec's, tech info, tips, settings and advice for the Stormer range.
Have a look here where there's a rather poor dia of the points set-up. Perhaps they'd email you a better copy?
Website:

https://www.ajsmotorcycles.co.uk/pre-74-stormer
I poke badgers with spoons.

User avatar
Posts: 464
Joined: Mon Nov 05, 2012 3:43 pm
Location: Cork, Ireland

Re: Stormer FB 370 - Reinstating Points Ignition

Postby Cjay59 » Sun Jan 20, 2019 12:02 am

My Stormer 250 has a Motoplat system, it was installed in 1981 and still runs today. It was installed by AJS Andover, I replaced the points because it gives you a much stronger, and once set up, reliable spark.

I would suggest you speak to Electrex World, I think it's Steve who developed their system for his own 410 Stormer, and ask him, "What could cause it to fail". I can't see how heat or vibration could be the cause.

My CDI unit is placed on the frame near the air filter, i use an unpainted bracket and have stripped away the frame paint for the best earth possible, it also runs the lights, mine is an Enduro, I run wires back to this point to complete all earth circuits. Some people want as short a HT lead as possible, so do place the unit under the fuel tank.

Check or replace your plug cap, trim the HT lead a couple of mm and screw it back in, a poor connection here is a simple fault to eliminate. At the same time check the wiring for any unwanted earthing from wear, I've protected the wires coming up from the bottom of the engine with a polyurethane pipe, they are quite exposed to knocks.

I ran the bike every day on points for about four years, it was my ride to work, but it was 6 volts, not so good for lights, and they were prone to shorting out from damp. I have no experience of the Electrex World system but I believe some alterations to your casings may have been needed to install it, I'm not absolutely sure that this is so, or would cause you an issue if you wanted to return to points, but worth checking before making a decision.

Member
User avatar
Posts: 3560
Joined: Mon Jan 01, 1990 12:00 am
Location: LONDON UK

Re: Stormer FB 370 - Reinstating Points Ignition

Postby clive » Sun Jan 20, 2019 8:22 am

A fellow club member recently helped me get my Honda XL250 running which was showing a weak spark and had a fault similar to yours. It would sometimes start and then stubbornly refuse to do so after dying or being stopped. Testing suggested the CDI unit was faulty but no improvement when it was replaced. We finally established there was a common earth cable for the CDI unit and the coil. This showed a high resistance. Cleaned up all the connections and the earthing point to the frame and it ran perfectly with the old CDI unit in place. i cannot say it was a permanent fix but i did around 30 miles on it before selling it on and the new owner rode it away!
clive
if it ain't broke don't fix

User avatar
Posts: 464
Joined: Mon Nov 05, 2012 3:43 pm
Location: Cork, Ireland

Re: Stormer FB 370 - Reinstating Points Ignition

Postby Cjay59 » Sun Jan 20, 2019 7:39 pm

Parts Manual Diagram

Parts Manual Diagram.jpg


Parts Manual Part Numbers

Part Numbers.jpg


By using the Part Numbers you can order parts from AJS Motorcycles Ltd by emailing them a list, or calling them, they should also have the Parts Manual if you need one, I would recommend getting one, I can scan these pages if they aren't clear enough.

If you save to your desk top you will get the whole picture.
You do not have the required permissions to view the files attached to this post.

Posts: 4
Joined: Mon Apr 09, 2018 10:15 pm
Location: Worcs UK

Re: Stormer FB 370 - Reinstating Points Ignition

Postby burga007 » Mon Jan 21, 2019 8:38 am

Thanks to everyone for your replies, really helpful!!

Return to Two Strokes

Who is online

Users browsing this forum: No registered users and 1 guest