Problem with valve springs

Information relating to the Matchless G80 or AJS Model 18 500cc Heavyweight.
Member
Posts: 18
Joined: Mon Aug 12, 2019 11:29 pm
Location: Punta del Este, Uruguay

Problem with valve springs

Postby Guille » Sun Sep 08, 2019 4:52 pm

I bought a set of valve springs from amoc-parts.com

After installing then I see that when the valve y pushed open the piece that holds the valve stem will run against the spring.
This only happens with the narrow spring.

Any tip on how to solve it?

ImageImage

Member
Posts: 1611
Joined: Mon Mar 24, 2014 5:44 pm
Location: Aberdeenshire

Re: Problem with valve springs

Postby Mick D » Sun Sep 08, 2019 5:04 pm

Hi

Do you have the old springs still? if so compare the bend at the top, does the new spring have a greater bend angle?

Your springs have a different profile to the ones fitted to my G3. Mine are also fitted in the opposite orientation, maybe try swapping the springs to see if it makes a difference:

Valve Springs 2.png


Regards Mick
You do not have the required permissions to view the files attached to this post.

Member
Posts: 18
Joined: Mon Aug 12, 2019 11:29 pm
Location: Punta del Este, Uruguay

Re: Problem with valve springs

Postby Guille » Mon Sep 09, 2019 12:08 am

Mick D wrote:Hi

Do you have the old springs still? if so compare the bend at the top, does the new spring have a greater bend angle?

Your springs have a different profile to the ones fitted to my G3. Mine are also fitted in the opposite orientation, maybe try swapping the springs to see if it makes a difference:

Valve Springs 2.png


Regards Mick

The old springs had a shallower bend angle

Member
Posts: 1611
Joined: Mon Mar 24, 2014 5:44 pm
Location: Aberdeenshire

Re: Problem with valve springs

Postby Mick D » Mon Sep 09, 2019 6:53 am

Guille wrote:The old springs had a shallower bend angle


Hi

Is the dimension indicated below smaller on the new spring? If so you should bring it to the attention of Club Spares, they may have received a bad batch.

Valve Spring Dim.png


What was your reason for replacing the springs in the first place?

Regards Mick
You do not have the required permissions to view the files attached to this post.

Member
Posts: 18
Joined: Mon Aug 12, 2019 11:29 pm
Location: Punta del Este, Uruguay

Re: Problem with valve springs

Postby Guille » Mon Sep 09, 2019 3:17 pm

Mick D wrote:
Guille wrote:The old springs had a shallower bend angle


Hi

Is the dimension indicated below smaller on the new spring? If so you should bring it to the attention of Club Spares, they may have received a bad batch.

Valve Spring Dim.png


What was your reason for replacing the springs in the first place?

Regards Mick

They were worn out at the spot where the spring presses against the metal that attaches to the valve stem

Member
Posts: 1611
Joined: Mon Mar 24, 2014 5:44 pm
Location: Aberdeenshire

Re: Problem with valve springs

Postby Mick D » Mon Sep 09, 2019 4:02 pm

Guille wrote:They were worn out at the spot where the spring presses against the metal that attaches to the valve stem


OK, so re-fitting the old ones isn't really an option. I think you need to dimensionally compare the new and old ones and report your findings to Club Spares - the new ones seem to be different to my originals and your old ones.

Regards Mick

Member
Posts: 18
Joined: Mon Aug 12, 2019 11:29 pm
Location: Punta del Este, Uruguay

Re: Problem with valve springs

Postby Guille » Tue Sep 10, 2019 10:27 am

Mick D wrote:
Guille wrote:They were worn out at the spot where the spring presses against the metal that attaches to the valve stem


OK, so re-fitting the old ones isn't really an option. I think you need to dimensionally compare the new and old ones and report your findings to Club Spares - the new ones seem to be different to my originals and your old ones.

Regards Mick

The new spring is 8mm shorter than the one being replaced and obviously with a very different curve.
Image

Member
Posts: 18
Joined: Mon Aug 12, 2019 11:29 pm
Location: Punta del Este, Uruguay

Re: Problem with valve springs

Postby Guille » Tue Sep 10, 2019 3:14 pm

Solved, getting a refund.
Image

Member
User avatar
Posts: 2655
Joined: Mon Jan 01, 1990 12:00 am
Location: HAMPSHIRE UK

Re: Problem with valve springs

Postby ajscomboman » Tue Sep 10, 2019 4:20 pm

The springs came from a reputable supply line, however it appears that the sample although very old with a label attached to it may not be a genuine original hence the difference. I have an original which I'm about to ship to Kettering to ensure the next batch is factory correct.

Return to G80 / Model 18

Who is online

Users browsing this forum: No registered users and 6 guests