Over charging a battery 1959 G3

Helpful information and requests for assitance and advice
Member
Posts: 1533
Joined: Mon Mar 24, 2014 5:44 pm
Location: Aberdeenshire

Re: Over charging a battery 1959 G3

Postby Mick D » Fri Aug 09, 2019 12:59 pm

Hi

I think you should take the feed to the Pazon unit from terminal 14 on the PRS8 switch and not directly from the battery. You could either ditch the isolation switch or hide it away as an anti theft device.

Why not run a temporary wire in and give it a test run? (4A to run an electronic ignition seems high to me so this would help with the regulator / rectifier diagnosis).

Note, I've used the 59 Owners Manual as a reference to how the PRS8 is wired in the assumption yours is as per design.

Regards Mick

Member
User avatar
Posts: 207
Joined: Tue Jun 26, 2012 9:58 am
Location: Lancashire

Re: Over charging a battery 1959 G3

Postby leobailey » Sat Sep 07, 2019 11:47 am

Hi Everyone,

I eventually tried the suggestion from Groily (08 Aug post) and fiddled with my wiring to feed the Pazon electronic ignition from the white wire connected to terminal 14 on the PRS8 headlamp switch.

As a result, the ammeter indicates a charge ( running at around 30mph ) of between 1 and 2 amps, with dipped headlamp and LED tail lamp on.

I feel a fair bit happier at that. My reason for initially going direct from the battery to the Pazon ignition was because the reproduction PRS8 switch has never inspired me. Any jiggling of the ignition key gave patchy results. :roll: :?:

I now leave the ignition permanently switched ON and stop the bike on the decompressor. I still used my separate keyed isolator switch to kill the feed from the battery to the ammeter.

All seems OK so far. It took me 20 + days to try Groily’s advice, but it worked so many thanks. The wife had me gardening for most of August.

Leo

Previous

Return to Help

Who is online

Users browsing this forum: No registered users and 11 guests